spamassassin troubles

I’ve got problems with updating my spamassassin and sa-compile to version 3.1.4-7
If you got also this post-installation error messages …

dpkg: error processing package spamassassin (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of sa-compile:
sa-compile depends on spamassassin; however:
Package spamassassin is not configured yet.

… then you have to enable the shell of the debian-spamd user to get rid of this error [1]!

Afterwards you will get the following error:

Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.30), passed through in regex; marked by <-- HERE in m/^(.{ <-- HERE ,200}).*$/ at /usr/share/perl5/Mail/SpamAssassin/PerMsgStatus.pm

So you should get the newest Revision of PerMsgStatus.pm and you will be fine [2]!

[1] https://askubuntu.com/questions/422264/how-to-debug-dpkg-configure-error-in-subprocess-post-installation#422697
[2] https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7404

Leave a Reply

Your email address will not be published. Required fields are marked *

*