Tag Archives: suspend

suspend with nvs140m

hello everybody!

again some probs after updating my machine. haven’t checked the suspend, so my lenovo t61p 6457BBG with the nvidia quadro NVS 140M freezed after waking up from suspend. here i’ve already found the solution, but haven’t applied it yet:

After trying out all these recipes on my 6457CTO waking up from suspend still did not work. Finally I came across a blog entry which pointed out the right way: [David Goodlad’s blog]. I realized that all the fixes proposing editing the acpi-support file or adding a kernel parameter acpi_sleep=s3_mode must be wrong because since hardy gnome-power-manager gets its information solely from hal. So setting up correct hal information is the right way but the proposed solution (creating a /etc/hal/fdi/information/lenovo.fdi file) did not work for me. Ok, but now step by step:

  • Revert ALL the proposed fixes from above. I found out that at least the lenovo.fdi solution is actually breaking the real fix. So for sure delete /etc/hal/fdi/information/lenovo.fdi
  • Find out about the excact hal name of your machine: hal-device | grep 6457 where 6457 is the model number of my t61, replace it with your own. In my case it spits out something like this: system.hardware.product = ‘6457CTO’. So now I know that hal identifies my machine as 6457CTO.
  • sudo vim /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-lenovo.fdi
    and add a section to the end of the file, just above the </device> tag and replace 6457CTO with your hal device name:
      <!-- T61 6457CTO uses NVidia driver -->
      <match key="system.hardware.product" string="6457CTO">
        <!-- Proprietray NVidia driver quirks -->
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
        <merge key="power_management.quirk.s3_bios" type="bool">false</merge>
        <merge key="power_management.quirk.save_pci" type="bool">true</merge>
      </match>
  • Now save and reboot. Now you might run into the problem of coming back from resume into a completely white screen where normally should be the password dialog. Entering your password blindly is not nice but at least you can resume.

thats all, and everything works fine now!